Ready to Upgrade?

Here’s more reasons to upgrade!

Please complete the form below for a quote.

Windows XP is no longer PCI Compliant. Due to processing regulations, MicroSale cannot be updated on Windows XP.

What operating system are you running?

  • Go to a computer running MicroSale
  • Go to Managers Menu > Register Options by Terminal > Exit to Windows
  • Click on the Start button
  • Go to My Computer (right Click)
  • Go to Properties
  • Look under Windows edition for the version
    1. On XP? Your operating system is not PCI Compliant which means your data is at risk. Please email us at info@microsale.net to upgrade your operating system